Recent Posts

Pages: 1 ... 8 9 [10]
91
DERBI Discussion / RATIO OF PREMIX FOR 70CC KIT?
« Last post by adzfletch98 on June 19, 2014, 01:02:14 PM »
I am thinking of rebuilding my derbi to a 70cc.
it is currently standard and its 2005.
i was going to buy a race crank, bearings & seals, new exhaust, 70cc top end kit & race clutch plates.
i was wondering if its better for me to go pre mix or will my oil pump keep up with the 70cc kit?
What is the ratio for 70cc pre mix?
thanks
92
DERBI Discussion / Need parts for GPR50
« Last post by Shrike on April 23, 2014, 02:03:13 PM »
Hello,  I need front and rear brake systems for my 2000 GPR50 project. I may change to a different system up front but I need the rear system for sure. Thanks...
93
DERBI Discussion / please help derbi terra!!!!!!
« Last post by richmh19 on December 17, 2013, 05:55:10 PM »
I have a 09 terra which ive had from 2010 and its recently started clicking from the middle like loud clicks and its going through my pegs and I can feel it all the time. When I go round a corner the bike feels like it's pulling and it's starting to worry me quite alot as its my daily bike to and from work please can someone help!!!!!! Thank you
94
DERBI Discussion / PLEASEEE HELP !!!!
« Last post by matty on October 14, 2013, 01:27:22 PM »
Hello there, i have recently purchased a Gilera SMT (Derbi senda) 50cc but it has a Derbi engine in it at the minute.
Basically when i rode it back from where i purchased the next morning, there was a small puddle of water on the garage floor, upon inspection i noticed there was a small hole in the engine, (very tiny) letting this water out, i realised that the temp sensor was long gone, and this was obviously the problem, so i bought a new one, fitted it and still, i am getting this puddle of water on the ground shortly after i use it.

Now is this tiny pressure outlet hole literally the size of a cocktail stick meant to be here? As this is where the water is coming from.
95
DERBI Discussion / Derbi terra 125
« Last post by mikg1 on September 08, 2013, 10:50:05 AM »
Hi all. I have a '59 plated terra. Great bike but only issue is that the odometer and clocks keep resetting, does anybody else have the same issue or fixed. Help please
96
DERBI Discussion / Derbi senda R 2004
« Last post by WheelieMan on August 31, 2013, 04:35:22 AM »
Hi there, I want to make my bike run better without changing the cc, so any suggestion ?  ;D
97
DERBI Discussion / derbi senda baja 125 2008
« Last post by didi on August 26, 2013, 05:46:11 AM »
hi i recently bought a derbi senda baja 125 2008 model ive been looking to get new parts but my vin number doesnt match the parts listed vin numbers mine is vthsc1d1a8h384956 how do i know im buying the correct parts thanks for any help the bike needs alot of work
98
DERBI Discussion / Re: Derbi Senda DRD Pro 50 Help Needed!!
« Last post by Derbi dave on August 11, 2013, 08:24:40 AM »
Hi mate have u checked the fuel filter that runs from the petrol tank under the seat area? It may be blocked so not getting anugh fuel just a thought worth checking
99
DERBI Discussion / Derbi predator 2stroke oil????
« Last post by Derbi dave on August 11, 2013, 08:20:47 AM »
Hi guys hope someone can advise on best or what 2stroke oil to use in my predetor liquid cooled 2000? I brought with 2stroke in tank already which is a red colour but not to sure if mineral/semi-synth or fully- synthetic oil! Can I just put any 2stroke oil in it on top of whats there? Can I mix both say it was mineral and put semi-synth on top of it or vice versa? Any help please ????
100
DERBI Discussion / Derbi Senda DRD Pro 50 Help Needed!!
« Last post by BrandonC on July 23, 2013, 06:30:28 PM »
Hi all,
         I have recently bought a Derbi Senda DRD Pro 50 as a non runner and i am having trouble finding what the issue with the bike could be so i thought you could all help :) :D

The bike runs (sort of) when you bump start it or kick it, although it soon cuts out if you give it a lot of revs it can actually run and we have done about 200 metres on it but as soon as the throttle is let loose the bike cuts out, the battery is fine but i think it could be something around the elctrical side as after inspection it appears the engine is perfect, my ideas are maybe there is a loose connection which is flickering on and off.

All advice taken so please help :)

Regards Brandon.
Pages: 1 ... 8 9 [10]